プログラム関係の備忘録。技術系記事1000記事以上を目指すブログ

Rails 5でbootstrap4を使う

  • 2019年5月7日
  • 2019年5月7日
  • Ruby
  • 141view
  • 0件

はじめに

前回、初めてのRuby on Railsをしてみました。
そして、UIライブラリとして何か使いやすいものがないかなーと弄っていると、使い慣れたbootstrapが使えるとのことでした。

見た目関係を後回しにしがちなエンジニアのあるある特性とは反対に、すぐ見た目から入りたい性格なので、とりあえず導入していきます。

Gemfileに追記

以下2行を追記します

gem 'bootstrap', '~> 4.1.1'
gem 'jquery-rails'

そして、プロジェクトのディレクトリ配下で以下のコマンドを実行

bundle install

assets配下にあるapplication.cssapplication.scssにリネームし、ファイル内容を追記する

@import "bootstrap";

同じくassets配下のapplication.jsに以下を追加する

//= require jquery3
//= require popper
//= require bootstrap

あとはいつもと同じようにbootstrapの形式で書いていくだけ

やっぱりレイアウトがきれいだとモチベーションも上がりやすいですよね